aboutsummaryrefslogtreecommitdiff
path: root/util/mkelfImage/configure.ac
diff options
context:
space:
mode:
authorWard Vandewege <ward@gnu.org>2008-08-06 20:37:38 +0000
committerWard Vandewege <ward@gnu.org>2008-08-06 20:37:38 +0000
commitebc92186cc9144aaacd37ca1ae94fcff60ec577a (patch)
tree8e92e08dd0d4df91416ee6f50afbaf2921d84663 /util/mkelfImage/configure.ac
parenta70872cfde84863637dba1fb00498dc8a61dba48 (diff)
Add the contents of buildrom's
packages/mkelfimage/mkelfimage-autoconf.patch packages/mkelfimage/mkelfImage-2.7-x86_64.patch to our svn copy of mkelfimage. Signed-off-by: Ward Vandewege <ward@gnu.org> Acked-by: Jordan Crouse <jordan.crouse@amd.com> These are the original commit messages from the buildrom svn tree: ----------------------------------------------------------------------- r61 | jcrouse | 2007-11-28 13:06:23 -0500 (Wed, 28 Nov 2007) | 9 lines [BUILDROM] Fixup mkelfimage My patch makes it so all targets use vmlinux and 2.7. Including the mkelfimage patch from Yhinghai Lu. Signed-off-by: Myles Watson <myles@pel.cs.byu.edu> Acked-by: Jordan Crouse <jordan.crouse@amd.com> ------------------------------------------------------------------------ r80 | jcrouse | 2007-12-10 13:56:40 -0500 (Mon, 10 Dec 2007) | 8 lines [BUILDROM] Fix breakage in the new mkelfimage autoconf scripts Whack the autoconf scripts in mkelfimage to allow us to pass our stack protection flags in. Signed-off-by: Jordan Crouse <jordan.crouse@amd.com> Acked-by: Corey Osgood <corey.osgood@gmail.com> ------------------------------------------------------------------------ git-svn-id: svn://svn.coreboot.org/coreboot/trunk@3473 2b7e53f0-3cfb-0310-b3e9-8179ed1497e1
Diffstat (limited to 'util/mkelfImage/configure.ac')
-rw-r--r--util/mkelfImage/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/util/mkelfImage/configure.ac b/util/mkelfImage/configure.ac
index 0c0e9c09fe..652b952de4 100644
--- a/util/mkelfImage/configure.ac
+++ b/util/mkelfImage/configure.ac
@@ -173,15 +173,15 @@ fi
dnl ---Output variables...
HOST_CC=$CC
-HOST_CFLAGS='-O2 -Wall $(HOST_CPPFLAGS)'
+HOST_CFLAGS="$HOST_CFLAGS -O2 -Wall \$(HOST_CPPFLAGS)"
dnl TODO: figure out how to set these appropriately for compilers other than gcc
-I386_CFLAGS='-Os -ffreestanding -Wall -W -Wno-format $(I386_CPPFLAGS)'
+I386_CFLAGS="$I386_CFLAGS -Os -ffreestanding -Wall -W -Wno-format \$(I386_CPPFLAGS)"
I386_ASFLAGS=''
I386_LDFLAGS='-static --warn-multiple-gp --warn-common'
dnl TODO: figure out how to set these appropriately for compilers other than gcc
-IA64_CFLAGS='-Os -ffreestanding -Wall -W -Wno-format -fpic -mconstant-gp -mauto-pic -fno-unwind-tables $(IA64_CPPFLAGS)'
+IA64_CFLAGS="$IA64_CFLAGS -Os -ffreestanding -Wall -W -Wno-format -fpic -mconstant-gp -mauto-pic -fno-unwind-tables \$(IA64_CPPFLAGS)"
IA64_ASFLAGS='-mconstant-gp -mauto-pic'
IA64_LDFLAGS='-static --warn-multiple-gp --warn-common'