aboutsummaryrefslogtreecommitdiff
path: root/util/me_cleaner/setup.py
diff options
context:
space:
mode:
authorNicola Corna <nicola@corna.info>2018-03-31 16:25:03 +0200
committerPatrick Georgi <pgeorgi@google.com>2018-04-06 06:54:14 +0000
commit8882ac55efd84142971657b17d9ab9733bb8348f (patch)
tree07cdb3096e45a207888f064072bf2e8afc7ce37c /util/me_cleaner/setup.py
parent7efdacd748f5292bfe09f2365ace14a614960dd0 (diff)
util/me_cleaner: Update to v1.2
Changelog: * Add support for the HAP/AltMeDisable bit * Add support for selective partition removal * Fix the ME permission removal on gen. 3 * Add public key match * Print the compressed size of the Huffman modules on gen. 2 * Wipe the ME6 Ignition firmware images * Fix the removal of the last partition on ME6 * Various region size fixes * Add manpage * Add setup.py * Print the value of the HAP/AltMeDisable bit The output image should be identical, except for the platforms affected by bugs (ME 6.x, but it's not supported by coreboot and ME 11.x with the -d option, but it's not being used in our build process). Overall, nothing should change when it's used with the CONFIG_USE_ME_CLEANER option. Tested on a Lenovo X220 and Sapphire Pure Platinum H61. Change-Id: I3d5e0d9af0a36cc7476a964cf753914c2f3df9d2 Signed-off-by: Nicola Corna <nicola@corna.info> Reviewed-on: https://review.coreboot.org/25506 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Philipp Deppenwiese <zaolin.daisuki@gmail.com>
Diffstat (limited to 'util/me_cleaner/setup.py')
-rwxr-xr-xutil/me_cleaner/setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/util/me_cleaner/setup.py b/util/me_cleaner/setup.py
new file mode 100755
index 0000000000..92fd359ad4
--- /dev/null
+++ b/util/me_cleaner/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/python
+
+from setuptools import setup
+
+setup(
+ name="me_cleaner",
+ version="1.2",
+ description="Tool for partial deblobbing of Intel ME/TXE firmware images",
+ url="https://github.com/corna/me_cleaner",
+ author="Nicola Corna",
+ author_email="nicola@corna.info",
+ license="GPLv3+",
+ scripts=['me_cleaner.py'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ ]
+)