aboutsummaryrefslogtreecommitdiff
path: root/util/coreboot-configurator/meson.build
diff options
context:
space:
mode:
authorSean Rhodes <sean@starlabs.systems>2021-11-12 08:54:50 +0000
committerMartin Roth <martinroth@google.com>2022-01-27 16:16:23 +0000
commit9c89e3ada2dd30d683c44364e8eea5de757b74eb (patch)
tree30e29cf5094559f82589dd7583aeac89c5a95592 /util/coreboot-configurator/meson.build
parentaef6de34263694a62f42135be1a97075ec3a2b7a (diff)
util: Add coreboot-configurator
A simple GUI to change settings in coreboot's CBFS, via the nvramtool utility. Test on the StarBook Mk IV running coreboot 4.15 with: * Ubuntu 20.04 * Ubuntu 21.10 * MX Linux 21 * elementary OS 6 * Manjaro 21 Signed-off-by: Sean Rhodes <sean@starlabs.systems> Change-Id: I491922bf55ed87c2339897099634a38f8d055876 Reviewed-on: https://review.coreboot.org/c/coreboot/+/59256 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Martin Roth <martinroth@google.com>
Diffstat (limited to 'util/coreboot-configurator/meson.build')
-rw-r--r--util/coreboot-configurator/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/util/coreboot-configurator/meson.build b/util/coreboot-configurator/meson.build
new file mode 100644
index 0000000000..b3175ccdba
--- /dev/null
+++ b/util/coreboot-configurator/meson.build
@@ -0,0 +1,12 @@
+## SPDX-License-Identifier: GPL-2.0-only
+
+project('coreboot-configurator',
+ 'cpp',
+ version: '8',
+ license: ['GPL2', 'CC BY-SA 4.0'],
+ meson_version: '>= 0.53.0',
+ default_options: ['prefix=/usr',
+ 'cpp_std=c++14'],
+)
+
+subdir('src')