summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeny Zinoviev <me@ch1p.io>2021-07-28 19:21:23 +0300
committerEvgeny Zinoviev <me@ch1p.io>2021-07-28 19:21:23 +0300
commit30d91f3b55c01a9dcc32c894db678801c7f9c1c6 (patch)
tree4396e2f8ba0701c67b93df88d44a51586ae7b070 /CMakeLists.txt
parent42df77cfe8cfc87c98f584875202c9ae95d6e019 (diff)
add wrapper script
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18493d0..c0eb30d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,15 @@
-cmake_minimum_required(VERSION 3.19)
+cmake_minimum_required(VERSION 3.10)
project(captive-netns-helper C)
set(CMAKE_C_STANDARD 99)
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- set(CMAKE_INSTALL_PREFIX /usr/local/bin)
+ set(CMAKE_INSTALL_PREFIX /usr/local)
endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
add_executable(captive-netns-helper main.c)
install(TARGETS captive-netns-helper
- RUNTIME DESTINATION bin) \ No newline at end of file
+ RUNTIME DESTINATION bin)
+install(FILES captive-portal.sh
+ PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ DESTINATION bin) \ No newline at end of file