aboutsummaryrefslogtreecommitdiff
path: root/util/nvramtool/nvramtool.spec
diff options
context:
space:
mode:
Diffstat (limited to 'util/nvramtool/nvramtool.spec')
-rw-r--r--util/nvramtool/nvramtool.spec50
1 files changed, 50 insertions, 0 deletions
diff --git a/util/nvramtool/nvramtool.spec b/util/nvramtool/nvramtool.spec
new file mode 100644
index 0000000000..1493604dca
--- /dev/null
+++ b/util/nvramtool/nvramtool.spec
@@ -0,0 +1,50 @@
+##
+# $Id$
+##
+
+Name: nvramtool
+Version: 2.0.1
+Release: 0
+
+Summary: coreboot utility program
+Group: System Environment/Base
+License: GPL
+Provides: nvramtool
+
+BuildRoot: %{_tmppath}/%{name}-%{version}
+
+Source0: %{name}-%{version}.tgz
+
+%description
+nvramtool is a utility for reading/writing coreboot parameters and displaying
+information from the coreboot table.
+
+At boot time, coreboot places a table (known as the coreboot table) in low
+physical memory. The contents of this table are preserved even after
+coreboot transfers control to the kernel and the kernel initializes itself.
+The coreboot table contains various system information such as the type of
+mainboard in use. It also specifies locations in the CMOS (nonvolatile RAM)
+where the coreboot parameters are stored.
+
+%prep
+%setup -n %{name}-%{version}
+
+%build
+make
+
+%install
+rm -rf "$RPM_BUILD_ROOT"
+mkdir -p "$RPM_BUILD_ROOT/usr/bin"
+mkdir -p "$RPM_BUILD_ROOT/usr/man/man1"
+cp nvramtool "$RPM_BUILD_ROOT/usr/bin"
+cp nvramtool.1.gz $RPM_BUILD_ROOT/usr/man/man1
+
+%clean
+rm -rf "$RPM_BUILD_ROOT"
+
+%files
+%defattr(-,root,root,0755)
+%doc ChangeLog README
+%doc README
+/usr/bin/nvramtool
+/usr/man/man1/nvramtool.1.gz