summaryrefslogtreecommitdiff
path: root/util/liveiso/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'util/liveiso/common.nix')
-rw-r--r--util/liveiso/common.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/util/liveiso/common.nix b/util/liveiso/common.nix
index 320971b57c..6c57dc333d 100644
--- a/util/liveiso/common.nix
+++ b/util/liveiso/common.nix
@@ -16,10 +16,17 @@
isoName = "${config.isoImage.isoBaseName}-${config.system.nixos.label}-${pkgs.stdenv.hostPlatform.system}.iso";
};
- # Tell the Nix evaluator to garbage collect more aggressively.
- # This is desirable in memory-constrained environments that don't
- # (yet) have swap set up.
- environment.variables.GC_INITIAL_HEAP_SIZE = "1M";
+ environment = {
+ variables = {
+ EDITOR = "nvim";
+ VISUAL = "nvim";
+ # Tell the Nix evaluator to garbage collect more aggressively.
+ # This is desirable in memory-constrained environments that don't
+ # (yet) have swap set up.
+ GC_INITIAL_HEAP_SIZE = "1M";
+ };
+ shellAliases.vim = "nvim";
+ };
boot = {
kernelParams = [