summaryrefslogtreecommitdiff
path: root/util/liveiso/nixos/graphical.nix
diff options
context:
space:
mode:
authorFelix Singer <felix.singer@secunet.com>2023-03-13 14:03:45 +0100
committerFelix Singer <felixsinger@posteo.net>2023-03-17 19:27:31 +0000
commit0e2fc554a778e2a47a9ad906a56159055c7187d1 (patch)
tree8484f0f782347c14c32dc4b535fa8bb1cc32ddef /util/liveiso/nixos/graphical.nix
parentd054bbd4f1ba1675486df38afdc186d9f31760f1 (diff)
util/liveiso: Move NixOS configs to subdirectory
Move the NixOS configuration into a subdirectory so that configurations for other distros can be added as well. Change-Id: I0462c1a6541878c973be4302c5c5e9e9bfaed2a6 Signed-off-by: Felix Singer <felix.singer@secunet.com> Reviewed-on: https://review.coreboot.org/c/coreboot/+/73684 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Elyes Haouas <ehaouas@noos.fr> Reviewed-by: Michael Niewöhner <foss@mniewoehner.de>
Diffstat (limited to 'util/liveiso/nixos/graphical.nix')
-rw-r--r--util/liveiso/nixos/graphical.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/util/liveiso/nixos/graphical.nix b/util/liveiso/nixos/graphical.nix
new file mode 100644
index 0000000000..8d51caf071
--- /dev/null
+++ b/util/liveiso/nixos/graphical.nix
@@ -0,0 +1,73 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+{ pkgs, lib, ... }:
+
+{
+ imports = [
+ ./common.nix
+ ];
+
+ hardware.pulseaudio = {
+ enable = true;
+ package = pkgs.pulseaudioFull;
+ };
+
+ security.polkit = {
+ enable = true;
+ extraConfig = ''
+ polkit.addRule(function(action, subject) {
+ if (subject.isInGroup("wheel")) {
+ return polkit.Result.YES;
+ }
+ });
+ '';
+ };
+
+ services.xserver = {
+ enable = true;
+ displayManager = {
+ gdm = {
+ enable = true;
+ autoSuspend = false;
+ };
+ autoLogin = {
+ enable = true;
+ user = "user";
+ };
+ };
+ desktopManager.gnome.enable = true;
+ };
+
+ users.users.user.extraGroups = [ "audio" "video" "input" ];
+
+ environment.systemPackages = with pkgs; [
+ firefox
+ gparted
+ pavucontrol
+ ];
+
+ # Remove unnecessary stuff
+ services = {
+ gnome = {
+ evolution-data-server.enable = lib.mkForce false;
+ gnome-online-accounts.enable = lib.mkForce false;
+ gnome-online-miners.enable = lib.mkForce false;
+ gnome-initial-setup.enable = lib.mkForce false;
+ gnome-browser-connector.enable = lib.mkForce false;
+ };
+ telepathy.enable = lib.mkForce false;
+ dleyna-renderer.enable = lib.mkForce false;
+ dleyna-server.enable = lib.mkForce false;
+ };
+
+ programs.geary.enable = lib.mkForce false;
+
+ environment.gnome.excludePackages = with pkgs; [
+ gnome.gnome-weather
+ gnome.epiphany
+ gnome.gnome-contacts
+ gnome-photos
+ gnome.gnome-music
+ yelp
+ ];
+}