aboutsummaryrefslogtreecommitdiff
path: root/src/mainboard/google/auron/Makefile.inc
diff options
context:
space:
mode:
authorMarc Jones <marc.jones@se-eng.com>2015-06-09 21:18:38 -0600
committerMarc Jones <marc.jones@se-eng.com>2015-06-13 18:09:20 +0200
commitd862121fbe6285be2f91a0c09058a22a775c0d19 (patch)
tree4ef78f4c720e49a81303f81ccfa957d2fcd64bf1 /src/mainboard/google/auron/Makefile.inc
parentf2dfef01e1fdf9d8218f0bc6ecfc3f943dc4d2a1 (diff)
google/auron: Add mainboard
Add the Google Auron Broadwell Reference Mainboard. It is based on the Google Peppy mainboard. It was merged from the following chromium.org commit: d20a1d1a22d64546a5d8761b18ab29732ec0b848 Change-Id: I716a79e198e91c428bd965fcd03665c2c7067602 Signed-off-by: Marc Jones <marc.jones@se-eng.com> Reviewed-on: http://review.coreboot.org/10500 Tested-by: build bot (Jenkins) Reviewed-by: Stefan Reinauer <stefan.reinauer@coreboot.org>
Diffstat (limited to 'src/mainboard/google/auron/Makefile.inc')
-rw-r--r--src/mainboard/google/auron/Makefile.inc33
1 files changed, 6 insertions, 27 deletions
diff --git a/src/mainboard/google/auron/Makefile.inc b/src/mainboard/google/auron/Makefile.inc
index 97eaccae6a..68ba413362 100644
--- a/src/mainboard/google/auron/Makefile.inc
+++ b/src/mainboard/google/auron/Makefile.inc
@@ -1,7 +1,7 @@
##
## This file is part of the coreboot project.
##
-## Copyright (C) 2012 Google Inc.
+## Copyright (C) 2014 Google Inc.
##
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -17,36 +17,15 @@
## Foundation, Inc.
##
+subdirs-y += spd
+
ramstage-$(CONFIG_EC_GOOGLE_CHROMEEC) += ec.c
romstage-y += chromeos.c
ramstage-y += chromeos.c
-ramstage-$(CONFIG_MAINBOARD_DO_NATIVE_VGA_INIT) += gma.c i915io.c
-
-smm-$(CONFIG_HAVE_SMI_HANDLER) += smihandler.c
-## DIMM SPD for on-board memory
-SPD_BIN = $(obj)/spd.bin
-# Order of names in SPD_SOURCES is important!
-SPD_SOURCES = Micron_4KTF25664HZ # 0: 4GB / CH0 + CH1
-SPD_SOURCES += Hynix_HMT425S6AFR6A # 1: 4GB / CH0 + CH1
-SPD_SOURCES += Elpida_EDJ4216EFBG # 2: 4GB / CH0 + CH1
-SPD_SOURCES += Micron_4KTF25664HZ # 3: Reserved / place holder
-SPD_SOURCES += Micron_4KTF25664HZ # 4: 2GB / CH0 + CH1
-SPD_SOURCES += Hynix_HMT425S6AFR6A # 5: 2GB / CH0 + CH1
-SPD_SOURCES += Elpida_EDJ4216EFBG # 6: 2GB / CH0 + CH1
-
-SPD_DEPS := $(foreach f, $(SPD_SOURCES), src/mainboard/$(MAINBOARDDIR)/$(f).spd.hex)
-
-# Include spd rom data
-$(SPD_BIN): $(SPD_DEPS)
- for f in $+; \
- do for c in $$(cat $$f | grep -v ^#); \
- do printf $$(printf '\%o' 0x$$c); \
- done; \
- done > $@
+smm-$(CONFIG_HAVE_SMI_HANDLER) += smihandler.c
-cbfs-files-y += spd.bin
-spd.bin-file := $(SPD_BIN)
-spd.bin-type := spd
+romstage-y += pei_data.c
+ramstage-y += pei_data.c