aboutsummaryrefslogtreecommitdiff
path: root/src/mainboard/google/auron/Makefile.inc
diff options
context:
space:
mode:
authorArthur Heymans <arthur@aheymans.xyz>2019-05-12 13:44:22 +0200
committerNico Huber <nico.h@gmx.de>2019-05-14 23:22:02 +0000
commitcadc70f7974db25144381b3ea26d4b660233f4dd (patch)
treede9e0677c328fe3d90389298c00f8831d0a6984d /src/mainboard/google/auron/Makefile.inc
parent57459dbeacb4759c3352206464b6c19b7add00d5 (diff)
soc/intel/broadwell: Move GPIO init to a common place
This also links the gpio configuration instead of including it as a header. Change-Id: I9309d2b842495f6cff33fdab18aa139a82c1959c Signed-off-by: Arthur Heymans <arthur@aheymans.xyz> Reviewed-on: https://review.coreboot.org/c/coreboot/+/32759 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de> Reviewed-by: Matt DeVillier <matt.devillier@gmail.com>
Diffstat (limited to 'src/mainboard/google/auron/Makefile.inc')
-rw-r--r--src/mainboard/google/auron/Makefile.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mainboard/google/auron/Makefile.inc b/src/mainboard/google/auron/Makefile.inc
index 170e1686da..c81aeaf0f6 100644
--- a/src/mainboard/google/auron/Makefile.inc
+++ b/src/mainboard/google/auron/Makefile.inc
@@ -32,3 +32,5 @@ subdirs-y += variants/$(VARIANT_DIR)
subdirs-y += variants/$(VARIANT_DIR)/spd
CPPFLAGS_common += -I$(src)/mainboard/$(MAINBOARDDIR)/variants/$(VARIANT_DIR)/include
+
+romstage-y += variants/$(VARIANT_DIR)/gpio.c