aboutsummaryrefslogtreecommitdiff
path: root/src/mainboard/google/auron/Makefile.inc
diff options
context:
space:
mode:
authorMatt DeVillier <matt.devillier@gmail.com>2018-09-14 21:39:00 -0500
committerMartin Roth <martinroth@google.com>2018-09-17 16:00:41 +0000
commit1b25f1b47c57e32f2a27480e12daa61331e456a3 (patch)
tree92b2f22a72f475155bd6f988ae3016e79e44b312 /src/mainboard/google/auron/Makefile.inc
parent99416035fac228f138f3e291a47173b66954b452 (diff)
google/buddy: Add board as variant of google/auron
Add google/buddy (Acer Chromeboase 24) as a variant of google/auron, with the following changes: - add buddy-specific variant code - add handling to auron for buddy's lan init, which no other variants have - add handling to auron's mainboard ACPI due buddy having different PCIe port assigments than all other variants Ported from Chromium branch firmware-buddy-6301.202.B, commit ebb82ce [Buddy: Lock management engine + SPI descriptor] Test: build/boot Linux on google/buddy using SeaBIOS and Tianocore payloads Change-Id: Ib76eef47677b72ddaef81a2decef189a5f20c20a Signed-off-by: Matt DeVillier <matt.devillier@gmail.com> Reviewed-on: https://review.coreboot.org/28613 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Martin Roth <martinroth@google.com>
Diffstat (limited to 'src/mainboard/google/auron/Makefile.inc')
-rw-r--r--src/mainboard/google/auron/Makefile.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mainboard/google/auron/Makefile.inc b/src/mainboard/google/auron/Makefile.inc
index d54a1c0bd5..170e1686da 100644
--- a/src/mainboard/google/auron/Makefile.inc
+++ b/src/mainboard/google/auron/Makefile.inc
@@ -23,7 +23,9 @@ smm-$(CONFIG_HAVE_SMI_HANDLER) += smihandler.c
romstage-y += variants/$(VARIANT_DIR)/pei_data.c
ramstage-y += variants/$(VARIANT_DIR)/pei_data.c
+ifneq ($(CONFIG_BOARD_GOOGLE_BUDDY),y)
romstage-y += variants/$(VARIANT_DIR)/variant.c
+endif
ramstage-y += variants/$(VARIANT_DIR)/variant.c
subdirs-y += variants/$(VARIANT_DIR)