summaryrefslogtreecommitdiff
path: root/gps/utils/configure.ac
diff options
context:
space:
mode:
authorIsaac Chen <isaacchen@isaacchen.cn>2018-12-31 10:55:08 +0100
committerTingyiChen <tingyi364@gmail.com>2019-08-13 11:54:40 +0200
commite5c53750f06e9d9739b45ec108260ead7ff80941 (patch)
treefe1d84884caefc481e994ae9c59c84b11fddd408 /gps/utils/configure.ac
parent3ac2a0309619515c9ac27a5b6ec7c212b86dc355 (diff)
wayne-common: Synchorize gps to P
* QC Tag: LA.UM.7.2.r1-04900-sdm660.0 Signed-off-by: Isaac Chen <isaacchen@isaacchen.cn> Change-Id: I34383e8fbf394b774f83f8d662873e8786ff1bbf
Diffstat (limited to 'gps/utils/configure.ac')
-rw-r--r--gps/utils/configure.ac29
1 files changed, 26 insertions, 3 deletions
diff --git a/gps/utils/configure.ac b/gps/utils/configure.ac
index a7ab9b4..639f8c4 100644
--- a/gps/utils/configure.ac
+++ b/gps/utils/configure.ac
@@ -28,9 +28,32 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
-PKG_CHECK_MODULES([LOCPLA], [loc-pla])
-AC_SUBST([LOCPLA_CFLAGS])
-AC_SUBST([LOCPLA_LIBS])
+# Checks for libraries.
+PKG_CHECK_MODULES([CUTILS], [libcutils])
+AC_SUBST([CUTILS_CFLAGS])
+AC_SUBST([CUTILS_LIBS])
+
+AC_ARG_WITH([core_includes],
+ AC_HELP_STRING([--with-core-includes=@<:@dir@:>@],
+ [Specify the location of the core headers]),
+ [core_incdir=$withval],
+ with_core_includes=no)
+
+if test "x$with_core_includes" != "xno"; then
+ CPPFLAGS="${CPPFLAGS} -I${core_incdir}"
+fi
+
+AC_ARG_WITH([locpla_includes],
+ AC_HELP_STRING([--with-locpla-includes=@<:@dir@:>@],
+ [specify the path to locpla-includes in loc-pla_git.bb]),
+ [locpla_incdir=$withval],
+ with_locpla_includes=no)
+
+if test "x$with_locpla_includes" != "xno"; then
+ AC_SUBST(LOCPLA_CFLAGS, "-I${locpla_incdir}")
+fi
+
+AC_SUBST([CPPFLAGS])
AC_ARG_WITH([glib],
AC_HELP_STRING([--with-glib],